shmendrick

Cache doesn't generate on map service publish

Discussion created by shmendrick on Mar 28, 2013
Latest reply on Oct 31, 2013 by mysony
When publishing a map service, I get the message 'cache is generating...', but the cache does not generate.

Checking the cache status shows 0% of tiles generated, no jobs in progress.

Using 'manage map tiles' tool, none of the scales that the map service is published at show in the dialog, and there is no way to add them.

Using the managecachetiles.py script included with server appears to be work, then eventually exits with a key error on 'job_status' (and no tiles have been generated).

I've tried publishing using both postgres and oracle based SDE databases and a fgdb on the server as datasources.

The ArcGIS Server log shows these errors:

1) IPersistStream::Save failed.
2) Instance of service 'xxxx' failed to process a request. AutomationException: Unspecified error
Very useful!

I'm running ArcGIS Server 10.11 an RHEL 6.

The only way I've been able to get tiles to generate is 'on demand' by manually panning around the map at the various scales.

It is only this particular map that has this issue. I can save a layer file of a layer in the map, pull that into a new mxd, and publish that with no problem.
I have tried saving everything and importing those layers into a new mxd, same issue.

The map design is overly complex, it seems that this is the issue, but I can't do anything about that.

What else can I investigate?

Outcomes