User does not have permissions to access 'system/publishingtools.gpserver

Discussion created by thaverkort on Feb 7, 2013
Latest reply on Feb 27, 2013 by thaverkort
Hi There,

Sorry for the tome...

My server setup:

ArcGIS for Server 10.1 sp1
ArcGIS for Desktop 10.1
Windows 2008 R2 VM
Web Adapter installed with Admin access through web adapter enabled (no shared key configured)
Cross domain policy installed
The database was successfully added to the Data Store

I have an MXD with source data from SDE (SQL Server installed on a different machine).  When I attempt to publish the MXD as a service, it creates the SD file, but fails on the publishing:

'Packaging succeeded, but publishing failed.  Unable to connect to publishing tools service.  Verify the service is up and running.  Please consult the GP Results Window for enhanced error description'. 

The service name contains no invalid characters.  I get the same error when attempting to create the service from Server Manager.

The next thing I did was to log into Server Manager.  All existing Map services seem to be running ok, can be restarted, and viewed in ArcMap.  Then I checked the System services to make sure the PublishingTools service is running ok, which is was.  However, when I clicked on Capabilities then on the rest service, I noticed that I didn�??t have permissions to view it (which may be a red herring): 

'User does not have permissions to access 'system/publishingtools.gpserver'.

Then I went into security, and added my Admin and Publishing roles to the service permissions, however, that didn�??t solve the problem.  I restarted the PublishingTools service.  It restarted fine, but didn�??t help. 

Eventually I was able to create one service in Server Manager by changing the URL from http://localhost:6080/arcgis/manager/ to http://localhost/arcgis/manager/

I'm still not able to create a service from ArcMap directly, even after I've confirmed that the server connection I've specified is running through IIS (http:///localhost/arcgis/admin)

Does anyone have any thoughts as to why I am not able to created a service from ArcMap?  Should I be able to see the REST details for the Publishing Tools system service?