stephanluther

Layers of a ArcMap Project are not displayed correctly after beeing published as WMS

Discussion created by stephanluther on Nov 15, 2012
Latest reply on Feb 18, 2014 by AngelynDavis
Hello,

i habe problem with the symbology of a WMS published with my ArcGIS Server.

In short: All of my WMS layers are listed in the table of contents, but with missing symbology and are, except of 3, not displayed i the map pane.


First some introducing information:

I use ArcDesktop 10.1 (Advanced) on Win7x64 and ArcServer 10.1 (ArcGIS for Server Advanced) on OpenSuse 12.

What do i want to do?:

I have a ArcMap  Project (mxd) with a lot of Layers (some grouped) that are derived from a polygon shape of personal geodatabase.
These Layers are joined with a table by an odbc connection from a mysql database, and are mainly symbolized with categories (unique values, many fields). So far so good.

This Project i want to publish as a wms service by using the ArcGIS Server.

I have an administrative and a publisher connection to my server, and can access arcgis manager.

When i'm publishing my service as a wms from inside of arcmap, everything seems to be fine.

I only got some errors, which should not (in my opinion) be the source of my problem:
Layers draw time may be affected by slow join access times.
Data source is not registered with the server and data will be copied to the server.
Standalone tables data source is not registered with the server and data will be copied to the server.
Layer doesn't have an attribute index on fields used for a join.
Map is being published with data copied to the server using data frame full extent.
Layer draws at all scale ranges.

Even the Preview of the Service works fine.

During the publishing process the data is copied to the server.
After publishing, ArcGIS Manager ist telling me that the service is running and i even got a nice preview thumbnail ;-)

When i'm accessing the wms with arcmap (i also tried google earth, arcgis online and the preview of ArcGIS Manager using the ArcGIS JaveScript API) the layers are listed correctly on the table of contents but ... but only 3 out of approximately 50 Layers are displayed.

I created a layerpackage out of the project and published it, with the same result. :-(

But if i'm exporting one of the layers as an shapefile, open it in a new instance of arcmap, readjusting (as good as possible) the symbolization and then publish it, i got what i saw in ArcMap (that's what i want).

I think it has something to do with the symbology, but i'm completely new at ArcGIS Server, so perhaps i miss something important.

Every help, idea, or link to an other thread would be appreciated.

Thanks,

Stephan

Outcomes