AnsweredAssumed Answered

Can't print graticules in a custom Layout Template with the ExportWebMap task?

Question asked by qwong on Nov 7, 2012
Latest reply on Nov 8, 2012 by qwong
Hi,

  Does anyone know how to get the graticules in a custom Layout Template to print with the Export Web Map task?

  This is what I did:

    Create Graticule Layout Template:

    1) I made a copy of "C:\Program Files\ArcGIS\Server\Templates\ExportWebMapTemplates\Letter ANSI A Landscape.mxd" & renamed it to "Letter ANSI A Landscape with Graticules.mxd"

    2) In "Table of Contents", I right-clicked "Layers" and selected "Properties" to open "Data Frame Properties"

    3) Under "Coordinate System", I chose my coordinate system

    4) Under the "Grids" tab, I clicked "New Grid" and made a new graticule using the "Grids and Graticules Wizard".  It seems to appear under "Layout View" (as long as you don't skip step 3)

    Run Export Web Map tool:

    5) In the "Catalog" tool, I opened "Toolboxes" > "System Toolboxes" > "Server Tools" > "Printing" > "Export Web Map"

    6) In the "Export Web Map" dialogue, I chose "C:\Program Files\ArcGIS\Server\Templates\ExportWebMapTemplates" as the "Layout Templates Folder".  I also chose "Letter ANSI A Landscape with Graticules" as the "Layout Template"

    7) I clicked OK to run the "Export Web Map" tool

    Publish the Printing Service:

    8) I opened "Geoprocessing" > "Results" window, expanded "Current Session" and right-clicked "Export Web Map".  I then clicked "Share As" > "Geoprocessing Service"

    9) I successfully published the service, setting the "Execution Mode" to "Synchronous" under "Parameters" when editing the service.

    However, when I try to use the Export Web Map task, setting the "Layout Template" parameter to "Letter ANSI A Landscape with Graticules", it prints the web map along with the date and the scale bar but it doesn't print the graticules!

    I have tried converting the graticule to graphics during step 4 but it still doesn't display the graticules.

    What am I doing wrong here?  Is this a bug?

Outcomes