nilsbabel

Spatial Analyst error in script tool with "Run Python script in process" unchecked

Discussion created by nilsbabel on Oct 26, 2012
Latest reply on Apr 23, 2013 by dmasante
Has anyone had errors with spatial analyst functions in script tools that have the property "Run Python script in process" unchecked?  I have a script which I've stripped down to a few simple lines.  The spatial analyst function I'm running is arcpy.sa.Reclassify.  (I've also tried ReclassByAscii and IsNull).  The script tool works fine when "Run Python script in process" is checked.  However, when it is unchecked the tool crashes.  The strange thing is when I have the statement in a python try/except statement the script tool just hangs and never crashes.  When I remove the try/except statement it just crashes with a generic ERROR 000714 error but no geoprocessing or traceback messages.  When I run the script outside of ArcGIS it works fine. 

I'm trying to run a multiprocessing script from a script tool which is why I need to uncheck "Run Python script in process".  I'm using ArcGIS 10.0.  Is this a bug?

Outcomes