jhansi131

Unable change input to run MakeXYEventLayer tool

Discussion created by jhansi131 on Oct 18, 2012
Hi,

I've created a MakeXYEventLayer geoprocessing package in ArcMap and trying to run it from my ArcGIS Runtime application.

Few issues I've encountered creating and running this package file -

The input table is an Access database(.mdb) file

1.  If I directly browse to the table from ArcCatalog, add to ArcMap and run the Make XY Event Layer tool from ArcToolbox, the tool runs fine. Then I analyzed the file with no High priority errors. Once I click share error is thrown - The table was not found. Error 999999: Error Executing function.

2. I create OLE DB database connection to the access database and add the table to ArcMap and follow rest of the steps. Now I am able to create gpk file successfully.

I run this tool from the application with following inputs ??? table (tablename), in_x_field (field name )and in_y_field(field name). The datatype for all parameters is GPString in UrlGeoprocessingSerivce.
This tool runs successfully only if the packaged data i.e. the table name from the results is used. If I give the path of other mdb file eg. ???C:\\Data\\IML.mdb\Sites??? it always fails ???
Error executing tool.: ERROR 000800: The value is not a member of SiteID | SiteModelName | SiteName .

How can I run this tool with dynamic data input.

Thanks!

Outcomes