Arc Hydro Longest Flow Path

Discussion created by r.i.fernandes on Sep 18, 2012

I was wondering if any one can help me with an error that has a lot of us here wondering what to do.

We are using arc Hydro to do some watershed analysis and have set up a model using model builder to automate the tasks.

The longest flow path tool is where the problem arises. It is unable to read the Raster ( the flow direction) and crashes at this point. The raster seems fine and other tools are able to read it.

The strangest thing is that the error is reproducable on all computers, except the laptop. We have different versions of arc hydro running on the desktop and changed to the laptop version , still the same error.

Even stranger is that a second model , exactly identical and built in the same way refuses to function on the laptop. We have tried to uninstall both arc hydro and ArcGIS but this does not help.

We have also tried the longest flow path tool out of the model and on it's own. It still refuses to work.

Details .... All computers on arc 10,  desktops are on Arc Hydro (version 2.0, April 28 2011)
Laptop ( the only computer where the tool works)  is on version (2.0, Oct 10 2011). We have tried this version on other computers. No luck.

Also unable to find this folder ,    C:\Projects\10_Final\ArcHydroTools\src\ApHydro\ArcHydroOp.vb:line 56579

Any Assistance is appreciated.



Error is

System.Runtime.InteropServices.COMException (0x80041018): Failed to open raster dataset
at ESRI.ArcGIS.SpatialAnalyst.RasterGeneralizeOpClass.Shrink(IGeoDataset Raster, Int32 numberCells, Object& zoneList)
at ESRI.APWR.ApHydro.ArcHydroOp.LongestFlowPath(ApLayers apLayers, Int32 debug, ITrackCancel& trackcancel, IGPMessages& messages, String& exMessage) in C:\Projects\10_Final\ArcHydroTools\src\ApHydro\ArcHydroOp.vb:line 56579