imihiro

Analyst3DTools.EditTin  doesn't Edit TinSurface

Discussion created by imihiro on May 8, 2012
I have got a TIN and a Polygon featureclass.
Both have the same spatialreference.
The polygon featureclass contains only one polygon feature, which is totally within the extent of TIN.

I clipped the TIN with the polygon, using the ArcMap 3D Analyst Tools-->TIN Creation-->Edit TIN Tool.The result TIN is correct.

I want to use Geoprocessor and Analyst3DTools. EditTin  Class to do the whole work. code sentences are Excuted, but the TIN is still the same, not clipped by the polygon feature class.
Here is my code:
  
      public static void GetClippedTinByPolygon()
        {
            Geoprocessor GP = new Geoprocessor();
            GP.OverwriteOutput = true;
            EditTin pEditTin = new EditTin();
            pEditTin.in_tin = "E:\\CZTinsPCS\\TinSurfaceCopy";
            pEditTin.in_features = "E:\\CZShapes\\PolygonRegionPCS.shp";
            GP.Execute(pEditTin, null);
        } 

Anyone succeeded in Edit TinSurface using Geoprocessor and EditTin Class?

----------------------------------
The function did works, just lack one parameter.
in ArcMap Toolbox, after select in put feature , set the "SF_Type" parameter to "hardclip", the result TIN will be Clipped by the feature class.
I think my problem will be solved, when I send the SF_Type parameter by code.

Outcomes