S506878

Spatial Analyst Extention and Syntax Errors

Discussion created by S506878 on Sep 19, 2011
Latest reply on Sep 19, 2011 by S506878
I have download the service pack two.  I have activated the extension and I have correctly entered my geoprocessing environment.  I have used some of the tools in ArcGIS 10 desktop successfully but this was my first time using the spatial analyst tools in ArcGIS 10.  I was trying to create a hillshade and slope from a dem but it failed with both.  The dem is in a geodatabase and I set the geodatabase as my workspace and tried to create the hillshade, in the geodatabase (failed).  I then tried to create the hilshade in a folder, outside of the geodatabase (failed).  I then tried a new name for the hillshade, rather than the default (failed).  I tried re-downloading the dem, in case it was a corrupt file and then creating a hillshade (failed).  I tried removing the dem from the geodatabase and putting it in a folder then creating a hilshade in the the folder (failed).  I think this is a spatial analyst tool extention problem not a corrupt data problem, especially since this is a class assignment and others using the same data haven't had this problem.  Also the errors I am getting are syntax errors.  The only thing that I changed is the output file (name and location) all other values were default values.  I then tried slope and had the same errors. Error codes: 010328(syntax error at or near new symbol NEW LINE) and 010267 (syntax error in parsing grid expression).  I am not using script or code just the standard tool.

Outcomes