nhieuduong

using arcgis engine runtime 10 to run program causes errors

Discussion created by nhieuduong on May 31, 2011
Latest reply on Jun 1, 2011 by agray1
hi

i am hoping that someone can give some insight as to why runtime is giving me errors when i run my own java written program with arcObjects.

the program is bundled in a executable jar file..i go to my terminal in linux(Centos 5) i source the init_engine.sh file and then i run the jar file ("java -jar MainWindow.jar")

i get alot of errors including...

Caused by: java.lang.RuntimeException: Can not use native code: Initialisation failed
at com.esri.arcgis.interop.NativeObjRef.<init>(Unknown Source)
at com.esri.arcgis.interop.Ocx.<init>(Unknown Source)
at com.esri.arcgis.controls.ToolbarControl.<init>(Unknown Source)
at com.esri.arcgis.beans.toolbar.ToolbarBean.a(Unknown Source)
at com.esri.arcgis.beans.toolbar.ToolbarBean.<init>(Unknown Source)
at com.aor.mapping.Map.<init>(Map.java:349)
at com.aor.seasimgui.MainWindow.<init>(MainWindow.java:260)
at com.aor.seasimgui.MainWindow.main(MainWindow.java:634)
at com.aor.testing.nhieu.Bootstrapper.main(Bootstrapper.java:23)

or these errors as well

java.lang.IllegalArgumentException: URI is not hierarchical
at java.io.File.<init>(File.java:363)
at com.esri.arcgis.interop.NativeLoader.getArcGISHome(Unknown Source)
at com.esri.arcgis.interop.NativeLoader.loadLibrary(Unknown Source)
at com.esri.arcgis.system.EngineInitializer.initializeVisualBeans(Unknown Source)
at com.aor.math.Compute.initializeArcGISLicenses(Compute.java:126)
at com.aor.seasimgui.MainWindow.main(MainWindow.java:633)
at com.aor.testing.nhieu.Bootstrapper.main(Bootstrapper.java:23)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:58)

i wasnt able to find much on the internet as to how to fix this problem, im hoping some one out there has encountered this problem before and would like to help another person out. Thanks in advanced for any help or comments that people took time to write. any info will help

Outcomes