adityaiiii

.NET ArcEngine application using Desktop license - not working

Discussion created by adityaiiii on Apr 8, 2011
Latest reply on Sep 2, 2011 by rudy50
did you resolve this issue ? Im facing the similar issue when I install my ArcGIS engine 10 .NET app on a machine with ArcGIS Desktop10 and No ArcGIS Engine runtime.

Im doing

ESRI.RuntimeManager.BindLicense(ProductCode.EngineOrDesktop)

and when I check the RuntimeManager.ActiveRuntime its showing "Desktop" , but when the execution reaches endinit function of AXMapControl in my form.designer.cs , Im getting  You must have a license to use this ActiveX Control. Prior to AxMapControl.EndInit() I have AxToc and AxToolbar controls which are  initializing (BeginInit and EndInit) without any problem. Why is that ? From what I see AxMapControl is a .NET activex control.

I also tried SRI.ArcGIS.esriSystem.IAoInitialize aoInitialize = new ESRI.ArcGIS.esriSystem.AoInitializeClass(); option, and once I run aoInitialize.Initialize(arcview-license product code), I can see the esrilicensestatus as checked out. Even after that its still breaking at AxMapControl.EndInit().

Any ideas ?

Outcomes