ARudowski@msd.utah.gov_slco

Definition Query Appears After Joining a Table to a Hosted View

Discussion created by ARudowski@msd.utah.gov_slco on May 21, 2020

When I join the table of a regular gdb feature to my hosted view and then try to look at my results the attribute table is just blank. After much frustration, I realize that in the course of performing the join it also sets up a definition query that looks like it's pointed at some sort of intermediate data. 

 

Here's the setup: (I'm using "Building Height" as my join field because it was an empty field and I cannot add fields to the hosted view)

 

The join is successful:

 

Empty attribute table:

 

Definition Query from nowhere:

Then I look in my previously empty definition query for the hosted view, and I see this thing just hanging out. It looks like it's pointed at some intermediate data used when it's creating the join because those are not the names of my layers. As soon as I remove this definition query I see all my joined features.

 

I'm at a loss for understanding why joining two tables also results in a definition query. I use definition queries regularly so the only reason I found this was by checking it to see if by chance I had one set, otherwise there is literally no indication that this is where someone should look.

 

What is happening here?

 

I'm running Pro 2.5.0

 

hosted feature layer views join table joined view layer join definition querry layer definition query definition-query

Outcomes