AnsweredAssumed Answered

Survey123 Feature Report - Points from Existing Feature Service - Map not working

Question asked by mtroxler_WMA on Feb 20, 2020
Latest reply on Apr 14, 2020 by aaron.nash

I'm working on a few projects that use Survey123 to interface with existing feature services hosted on AGOL.  The basic premise is asset inspections, so the geometry is pre-existing and accessed through the Survey123 Inbox feature on tablets in the field.  I am using Survey123 to update a few attribute values and then create related inspection table records.  When I attempt to run a feature report from my data, I'm having trouble with maps.

  • This is specific to point geometry from an existing feature service hosted on AGOL.  Other projects I have in Survey123 that create their own feature services and allow users to create point geometry through the Survey123 mobile app create maps successfully.
  • This only happens with point geometry.  Polyline geometry works as expected.  I do not have polygon geometry features in these projects, so I cannot comment on polygon mapping.
  • The map does not center on the selected feature when using Survey123 on an Android tablet.  Instead, it centers in Ecuador (my projects are in Maryland, USA).  It's as if the Longitude is reading correctly, but the Latitude value is being interpreted as 0.
  • In the preview pane to the right when I select a record on the Survey123 website in data view the map centers at 0,0 (I have to manually zoom out to see land masses), and it does the same thing when I export a preview of my feature report.  I'm still in the iterative process of formatting my reports, so I have not spent credits to generate a "final" exported copy.  My survey successfully reads the geometry details using the pulldata function to extract X, Y coordinates, but the preview pane to the right does not display values in Lat: Lon: above the preview map (screen shot below).
  • Note that in addition to my custom report, I have also tested the sample report generated by the Survey123 website and the map in the sample report does the same thing without any customized settings.

 

Does anybody have any ideas/suggestions?

Outcomes