AnsweredAssumed Answered

Arcgis Runtime Xamarin forms - Android = No Map

Question asked by Digriz77 on Dec 10, 2019

Hi,

Im using Visual Studio 2017, arcgis runtime 100.6

 

Im looking at making a xamarin forms cross platform app with .net runtime.  Im looking at making android, ios and windows.

 

i have downloaded the .net runtime  sdk from esri and installed.

 

I created the visual studio project using the arcgis runtime app (xamarin.forms....

 

It creates it perfect.  I can run the uwp and it works and i see the map.

 

if i then try and run the android app it loads.  but i get a grey window where the map should be.  and the very bottom a white status bar says Powered by Esri.

I have tried numerous android devices for testing...all show a grey window where the map should be.

 

i then tried standalone android, i tried just creating the xamarin and using nuget to get the arcgis runtime.  I always get a grey window.

 

But it works in UWP.

 

Is there something im doing wrong.  I followed the guide. I just cant think what is wrong.

 

David.

Outcomes