AnsweredAssumed Answered

Visualizing route layer on ArcPy Jupyter Notebook (ArcGIS) does not work!

Question asked by d4001628@urhen.com on Dec 8, 2019
Latest reply on Dec 13, 2019 by d4001628@urhen.com

I tried to visualize the route between two points using ArcPy in a Jupyter notebook. The network module is activated in my Esri account. Even though it visualizes the map I can't see the route on that as the Tutorial shows.

Here is the code I used. I guess the problem with visualization. However I can see the following message on the console. I can see the route Results but the problem is with displaying that. Also I can render the maps without routing layers. 

 

> [esri.views.LayerViewFactory] Failed to create view for layer 'Terrain3D, id:worldElevation' of type 'elevation'

 

 

 

(I tried with both Windows and Linux, Esiri Notebook environments and the result is still the same )

 

from copy import deepcopy
from datetime import datetime
from IPython.display import HTML
import json
import pandas as pd
from arcgis.gis import GIS
import arcgis.network as network
import arcgis.geocoding as geocoding

 

 

user_name = 'user'
password = 'pw'
my_gis = GIS('https://www.arcgis.com', user_name, password)

 

route_service_url = my_gis.properties.helperServices.route.url
route_service = network.RouteLayer(route_service_url, gis=my_gis)

 

stops = '''-3.203062,55.906437; -3.190080,55.935570'''

 

route_layer = network.RouteLayer(route_service_url, gis=my_gis)
result = route_layer.solve(stops=stops,
   directions_language='en-US',
   return_routes=True,
   return_stops=True, return_directions=False,
   return_barriers=False,
   return_polygon_barriers=False,
   return_polyline_barriers=False)

 

my_map = my_gis.map('Braidburn Valley', zoomlevel=13)
my_map

 

Thanks. 

Outcomes