AnsweredAssumed Answered

Problem with html display inline attributes with arcade expression in a popup

Question asked by jfaron44 on Sep 16, 2019

I have set up a rather lengthy popup configuration in a Web Map, ArcGIS Enterprise 10.6.1, that uses html display inline attributes with an arcade expression, as described in this forum link as well as others. It works fine, but after I save the map, close it and reopen it (or just reload the Web Map in the browser after saving it), all of the inline display attributes are gone, leaving only the expressions.

Below is a snippet of the html in the popup, with the inline attributes and expressions:

<b>Inspector:</b> {INSPECTOR}<br /><b>Date:</b> {INSPECTION_DATE} <br /><b>Structure #:</b> {STRUCTURE_NO}<br style="display:{expression/expr5}" />{expression/expr0}<br style="display:{expression/expr6}" />{expression/expr1} <br style="display:{expression/expr7}" />{expression/expr2}<br style="display:{expression/expr8}" />{expression/expr3}<br />Voltage: {VOLTAGE}<br />Structure Type: {STRUCTURE_TYPE} 

And here is what is left after saving and then reloading the map:

<b>Inspector:</b> {INSPECTOR}<br /><b>Date:</b> {INSPECTION_DATE} <br /><b>Structure #:</b> {STRUCTURE_NO}<br />{expression/expr0}<br />{expression/expr1} <br />{expression/expr2}<br />{expression/expr3}<br />Voltage: {VOLTAGE}<br />Structure Type: {STRUCTURE_TYPE} 

All of the inline  style="display:{expression/expr*} " are just not there on re-load.

An example of a display expression:

if(isEmpty($feature["CIRCUIT_1"])){
return "none"
}else {
return "inline";
}

Is there something that I am missing or doing wrong? Or is this a software limitation?

 

Thanks,

 

Jim Faron

TEP

Unisource Energy

Outcomes