AnsweredAssumed Answered

Setting Geoportal / ArcGISPortal using LDAP

Question asked by yocki78 on Aug 28, 2019
Latest reply on Sep 2, 2019 by yocki78

Hi,

 

I succesfully putting in parameter in Geoportal administrator (Portal Administrator Directory) with LDAP.

This is the paramater that i use :

{
"type": "LDAP",
"properties": {
"userPassword": "mysecret",
"sAMAccountName": "uid=username,ou=User Accounts,ou=xxx,ou=yyy",
"caseSensitive": "false",
"userEmailAttribute": "mail",
"usernameAttribute": "uid",
"userFullnameAttribute": "cn",
"ldapURLForUsers": "ldap://myserver.sumtin.com/ou=User Accounts,ou=xxx,ou=yyy,dc=sumtin,dc=com",
"isPasswordEncrypted": "true",
"userSearchAttribute": "sAMAccountName"
}
}

Note : That parameter above is not exactly the same as Esri suggested. I changed the "user" parameter into "sAMAccountName". If its not changed, the configuration will give out error "Failed to connect to the user store."

 

However, when I try to add member in Geoportal (Geoportal -> Organization -> Add members -> "Add members based on existing enterprise users", there is no users come up. The list is empty. Here is the picture :

it turns out that even-though it says "successful" during the Update Identity Store, it is actually not able to connect to the identity store. There is error when I try to search users in Get Enterprise User (portaladmin -> Home -> Security -> Users -> Get Enterprise Users) that says :

 

"Error

[LDAP: error code 1 - 000004DC: LdapErr: DSID-0C0907C2, comment: In order to perform this operation a successful bind must be completed on the connection., data 0, v2580]

"

It seems to me that I need to bind it correctly first before able to list all the users. 

Any idea on how I should fix this problem ?

 

thanks

 

FYI : ArcGIS Portal 10.6.1; Browser is IE 11

 

@ PMcNeilly-esristaff Please help.

Outcomes