AnsweredAssumed Answered

Cannot Register the Managed Database for ARCGIS Server

Question asked by aeryavec on Jul 16, 2019
Latest reply on Jul 30, 2019 by aeryavec



When trying to register the managed database for the ArcGIS server 10.5 through ArcCatalog it appears successful and will validate, but in the logs I get error 7415 (Failed to update the data store connections file, Registration of database is incomplete, Please re-register database).


When I subsequently try to deploy a FeatureService through ArcMap it fails with error 001369 (failed to create service) after failign to get the server's server only enterprise database.


I have tried changing the permissions on the config-store folder to give full control to all, and have also tried changing to a fresh config-store folder.


I have tried restarting the server, and unlocking and restarting the publishing tools service.


For the connection to the enterprise geodatabase I have tried connecting with the sde user, the sa user, and the ./arcgis service account user.


This occured when I was trying to connect to a freshly created geodatabase (which I did while working a separate issue) - I have been able to register the database and deploy feature services on this machine before.


Any help would be greatly appreciated, thank you.