AnsweredAssumed Answered

survey123 new bug - non-required field is being required only in newest version of iOS app

Question asked by jakethepainter on Jul 11, 2019
Latest reply on Aug 6, 2019 by JTedrick-esristaff

I have a survey which I've been using for a while in the iOS app.  When I updated to 3.5.164 Survey123 the other day, all of a sudden one question which is not required is being required by the app.  There's no red asterisk next to it and there is no validation logic, but the survey keeps returning to that question to require me to enter a value.  The field in the hosted feature service shows that it is nullable.


Users who have the previous version of the app are not seeing the behavior with the same exact survey.

 

I tried to republish the survey with the latest version of Survey123 Connect, but that did not change the behavior.

I tried to delete the app on my iPad and redownload the whole app, and that did not change the behavior.

 

The same behavior is present in the latest version of the preview window in the Survey123 Connect app on my Windows machine.

 

What's more, I can't spot the pattern that would make this question different from several others in the same survey.

 

I've attached the excel form that is driving the survey.  The only question that is exhibiting the behavior in the survey with the latest version is NUMANCHORRODS.

Attachments

Outcomes