AnsweredAssumed Answered

Sync local changes to survey's feature service

Question asked by NDierks@BoxElder on Mar 1, 2019
Latest reply on Mar 15, 2019 by NDierks@BoxElder

I'm trying to work out how to update a hosted feature service used by Survey123 by pushing said updates from a local geodatabase. Here's the background of what I've done and am hoping to accomplish:

 

  • I have water utility data in a geometric network (file geodatabase) that I edit using ArcMap 10.6.
  • I created a relationship class with the hydrants layer and a table for recording flow testing.
    • The relationship is based on GlobalID/GUID.
  • I published the hydrants layer as a hosted feature service, and then created a survey based on that service using Connect.
    • The intent of the survey is to only create new records in the related table. The data in the parent hydrants layer is visible but read-only.
    • This process worked out alright during testing.
  • I then downloaded the data and updated the local table (in the fGDB) with the new records created in the hosted table.
    • Again, looking at the related hydrants, this seemed to work fine.
  • As a test, I decided to edit the local hydrants layer (added a new record using ArcMap).
  • Then I switched to ArcPro, added the layer, and clicked Sharing > Overwrite Web Layer.
    • I'm thinking this is where I broke it...
  • When I went to check (both using the field app and on the Survey123 website), I started running into problems:
    • On the Data page: All records display on the map and in the table just fine. However, when clicking any record to open the Individual Response pane, the pane loads indefinitely, never displaying any data.
    • On the Analyze page: Statistics display just fine for the fields in the parent layer, but when I scroll down to where the repeat would start, again it just loads indefinitely.
      • (I did not check the Analyze page before I broke things, so I'm not sure if it was supposed to work anyway)
    • In the field app: Refreshing the Inbox gets stuck on "Searching for Surveys". If collecting a new record, I can fill it out just fine, but it hangs when trying to submit the survey.

 

I'm guessing something went wrong when I tried to update the hosted layer with the local feature class. Is there a different way to sync local changes to the hosted layer? Did I just goof up and miss a critical step or setting? Or is there no reasonable solution to the workflow I'm trying to accomplish? I can do my best to describe any of these steps in more detail if needed.

Outcomes