AnsweredAssumed Answered

.csv hosted feature layer does not draw

Question asked by PolicyPets on Oct 22, 2018
Latest reply on Oct 30, 2018 by PolicyPets

I am very new to GIS. I'm using ArcGIS online to create a point feature layer displaying several different facility types with the goal of creating an app featuring the "near me" widget.

 

I have no trouble when I add the .csv directly to the map viewer, but when I add the .csv as a hosted feature layer, none of my features draw. So far I have tried:

1) Uploading and geocoding using coordinates, confirming coordinates, reuploading (there are only about 1300 features total),

2) Uploading and geocoding using addresses, confirming addresses, reuploading (using about 100 features for test), and

3) Adjusting which part of the dataset ArcGIS online draws, but nothing will show.

 

All of my attempts have resulted in feature layers that do not draw. Also, there is always an error viewing the data table for these featured layers. 

 

I would just shrug and keep adding the data directly to the map view instead of as a hosted feature layer, but when I do this I cannot use this layer as the searchable layer in the attribute list of my web application (for the "near me" widget).

 

 

I have tried to find similar guidance, but it seems there are a few different types of related issues to this and I am totally confused about where to begin. Any insight, guidance or help into either 1) how i can use the near me widget with a layer added through the map viewer, and/or 2) how to troubleshoot my hosted feature problems would be greatly appreciated!

 

 

Thank you!

Outcomes