AnsweredAssumed Answered

Why is the Overwrite Web Layer operation failing?

Question asked by Bill_Schlatter on Oct 2, 2018
Latest reply on Oct 9, 2018 by KKramer-esristaff

My organization is currently getting ready to update a large portion of our data on ArcGIS Online, and in order to minimize the updates necessary to our various webmaps, we're trying to use the ArcGIS Pro feature Overwrite Web Layer.  However, the user account that hosts the vast majority of this data can't seem to make it work.  It doesn't seem to be user error - an identical workflow produces the expected results when done using my own user account. 

 

Whenever we try overwriting to our main hosting account, however, we get this error message (Screenshotted in the attachment):

"Cannot overwrite <layer name>.  Please configure that you are signed in as the web layer owner and the location of the item has not changed." 

(The odd word choice is accurate, as you can see in the screenshot)

 

We are logged into the correct account in both ArcGIS Pro and ArcGIS Online.  The location of the item has indeed not changed since being uploaded.  We've tried a variety of fixes, many based on other questions from people having trouble with the Overwrite Web Layer feature.  These include: Renaming layers and/or folders to remove all spaces, moving the layer to the account's root directory in AGO before trying to overwrite, and changing ownership of the layer in AGO to my user account.  None of theses options have worked, and in the last case, only layers moved from our main hosting account threw the error message - datasets uploaded directly to my account can be overwritten without issue. 

 

We know that we can always upload the datasets anew, but since many of them are referenced in active webmaps, that creates a lot of extra work tracking down and updating all the webmaps as necessary.  Also, the Overwrite workflow is one we expect to be using repeatedly in the future if we can get the issues worked out, so we'd like to know how to make it work reliably. 

 

Does anyone have any experience with this problem?  Or suggestions for workarounds?

Attachments

Outcomes