fiona.renton

Intermittent errors with IE 11 and JSAPI4.8 - Should I go back to JSAPI3.x?

Discussion created by fiona.renton on Sep 21, 2018
Latest reply on Oct 15, 2018 by fiona.renton

I have some interactive maps with geocoding, goTo, identifyTask and popups that work fine in Chrome, FireFox and sometimes in IE. They don't really need version 4, but were easy to convert to 4.x. My version of IE 11 doesn't like it.

I get intermittent errors in IE11 that go away after clearing the cache and reloading the page, but then come back after a while.

 

After a while IE throws an error and a simple counties featureLayer does not load:

esri.layers.graphics.controllers.SnapshotController] [snapshotcontroller:tile-request-failed]: Failed to query for features

[snapshotcontroller:tile-request-failed]: Failed to query for features

 

Also the popup (view.popup) stops working after a while, but does not give any errors.

Then when zooming out it loads no layers. 

 

I don't need 3D so I should just keep writing JS in version 3.x until version 3 is officially deprecated?

Has anyone else come across this issue?

 

and Yes..I have not opened a ticket 

Outcomes