AnsweredAssumed Answered

FGDB to EGDB

Question asked by jborgion Champion on Sep 18, 2018
Latest reply on Sep 19, 2018 by jborgion

ArcGIS desktop 10.5.1; ArcGIS 10.3.1 (EGDB) and SQL 2014.

 

I've encountered a very strange situation and after beating my head against the computer screen for much of the day, I'm at wits end.

 

I have a script that used to truncate an existing feature class in an EGDB and then append fresh data from a FGDB source feature class.  I discovered it isn't working so set out to see why.

 

Boiling down the past five hours, I can not in any way shape or form move the FGDB feature class to the EGDB. When I try just the append geoprocessing tool, I get an 'unspecified error'.  When I look at the original target data feature class, it has 

 

Shape.STArea() and Shape.STLength()

 

while the source data has (fgdb) has

 

Shape_Length and Shape_Area

 

I created an empty feature class in the EGDB, importing the schema of the source data and still get the Shape.ST####() fields; If I try the no test option with append tool, I am not given any option to map the the shape fields, and  it bails out.  Using the test option, the process just seems to hang and then eventually bails out with a ton of WARNING 000597 which says:  

 

000597 : Failed to insert input record with FeatureID <value>.

Description

A record/feature from the input could not be inserted into the output table/feature class due to problems with one of the field's values. Potential causes for this are

  • The input record's text fields contain values which are longer than the output field.
  • The input record fields contain <NULL> values, but the output or target field does not allow NULL.
  • The input feature's geometry has problems (run Check Geometry on the input).
  • The input feature is outside the allowable extent (x, y, z, or m) of the output feature class.

 

 

A few have ERROR 000224:

000224 : Cannot insert features.

Description

The tool failed to write records to the output feature class or table. This error is typically the result of mismatched field definitions between incoming features and the output feature class or table.

 

 

I tried a Feature Class to Feature Class out of desperation, and it bails out as well with 'unspecified errors'.

 

The login I'm using is an admin connection so permissions shouldn't be an issue.  

 

For a free taco, who can tell me what the heck is going on?

Outcomes