AnsweredAssumed Answered

How can I use a Python 3 runtime environment with ArcGIS Server services?

Question asked by ftonini_msugis on Sep 3, 2018

Everyone,

 

I am aware that ESRI provides instructions on how to install a python 3 runtime environment for a Linux ArcGIS Server installation. However, there is not a clear explanation on whether the aforementioned solution will apply to web services (e.g. geoprocessing services) published on ArcGIS Server for Linux or not. For example, if I publish a geoprocessing service that uses a number of libraries that only work with Python 3.5.x and later, how can I set up ArcGIS Server to use the python 3 runtime environment (installed with conda) as opposed to the default 2.7.x environment? Any help will be much appreciated.

Outcomes