Map_Sync

Creating a tile pkg. "layer type not supported"

Discussion created by Map_Sync on Sep 1, 2018

[Spoiler alert... I figured out what I was doing wrong.  I'll leave most of it in hopes that it helps debug someone else.]

 

I'm trying to copy a big .GEOTIF file of population grids from ArcGIS Pro out to a tile package I can use in .  I'm trying to follow the docmentation that reads:

 

Publish the GeoTIFF file as a tile service to ArcGIS

 

Add the GeoTIFF file to ArcMap or ArcGIS Pro, create a tile service from the file, and publish the service to ArcGIS . The GeoTIFF file can be used in web maps or applications. 

 

Build a tile package in ArcGIS Pro and upload to your organization
Use the Create Map Tile Package geoprocessing tool to create a tile package, add the package to your organization, and publish a tile layer.

1) Open the project that contains the data you want to package.
2) Open and run the Create Map Tile Package geoprocessing tool.
3) When your tile package has finished generating... .

 

But when I try to run the Create Map Tile Package geoprocessing tool in Pro, it failed.

 

 

 

 

It took me a long time to realize that the tool was unhappy about my having a base layer as part of the map, even though it was deselected.  Once I removed it altogether, the tool ran fine. 

 

P.S.  Have care in setting the "Detail level" count.   "Levels" are the various permissible zoom levels.  I set the detail level at 1 on my first try and got a layer that only displays when I look at my map from deep space.  I next set it to 20 (the max) and ran it, for the next couple of hours, until I gave up waiting and turned it off.  Thirteen layers worked well.

Outcomes