AnsweredAssumed Answered

No Data exception opening runtime geodatabase

Question asked by brian.marchionni on Aug 29, 2018

I'm writing a Xamarin.Forms application targeting iOS/Android/UWP. Runtime 100.3, I also tried 100.2.1

 

I'm attempting to side load a runtime geodatabase .geodatabase that I created in ArcGIS 10.3.1 for Desktop by adding a few layers to a .mxd and then clicking File->Share As->ArcGIS Runtime Content...

 

I then copied the output .geodatabase file into the path of my application and load it with this code:

 

if (System.IO.File.Exists(System.IO.Path.Combine(Storage.PublicFolderPath, "db.geodatabase")))
{
    Geodatabase gdb = await Geodatabase.OpenAsync(System.IO.Path.Combine(Storage.PublicFolderPath, "db.geodatabase"));

 

    foreach (GeodatabaseFeatureTable ft in gdb.GeodatabaseFeatureTables.Reverse())
    {
        FeatureLayer fl = new FeatureLayer(ft);
        _map.OperationalLayers.Add(fl);
    }
}

 

It works fine on iOS/UWP but on Android I get an unhandled exception trying to execute:

Geodatabase.OpenAsync(...)

 

Unhandled Exception:

Esri.ArcGISRuntime.ArcGISRuntimeException: No data occurred

 

And thats all the info I get. I've tried a few different android devices and emulators and it always throws the same error. I tried modifying my database to remove some layers / tables but that didn't help. I'd think it was a data issue but it works find on iOS/UWP.

 

Thanks for your help,

 

Brian

Outcomes