AnsweredAssumed Answered

WMS from ArcGIS Online not showing in Python API script

Question asked by jbridwell_Dewberry on Aug 16, 2018
Latest reply on Aug 20, 2018 by jbridwell_Dewberry

I have a Web Map Layer (Prelim_CSLF) in my ArcGIS Online content that is not showing when I call it from the ArcGIS API in a Python script. The Layer comes from a public web mapping service. As you can see, there are other layers in my contents. The ACS Feature Layer also comes from an outside service. enter image description here

In my script, I use the API to connect to my ArcGIS Online content and just want to list the items there.

agol = GIS("http://<arcGIS Online url>", "<username>", "<password>") agolList = agol.content.search("") agolList

Results =

[<Item title:"void_poly2" type:Feature Layer Collection owner:>,   <Item title:"PANYNJ_Charrette_Data"  type:Feature Layer Collection owner:>,   <Item title:"Map_Tour_Fianl" type:Feature Layer Collection owner:>,   <Item title:"April3_2018_update" type:Feature Layer Collection owner:>,   <Item title:"VA_Port" type:Feature Layer Collection owner:>,   <Item title:"GTS_Lidar_Project_Boundaries" type:Feature Layer Collection owner:>,   <Item title:"PR_SDE_QC_Batch4" type:Feature Layer Collection owner:>,   *<Item title:"ACS" type:Feature Layer Collection owner:jbridwell>*,   <Item title:"East_Donegal_Water_Utility_Network" type:Feature Layer Collection owner:>,   <Item title:"coastal_dg_polygons" type:Feature Layer Collection owner:>]

However, I am not seeing the Prelim_CSLF layer. I do see the ACS layer though (starred *). When I try agol.content.search("Prelim_CSLF", item_type="Map Image Layer") it just returns an empty []. What is the problem here?

Outcomes