AnsweredAssumed Answered

Launching Survey 123 with a url from the Workforce Field Map works on iOS but not Android

Question asked by dvonckesri-southafrica-esridist Employee on Aug 3, 2018
Latest reply on Oct 16, 2018 by chris.blinn

Hi All

We are doing a proof of concept with Workforce, Navigator and Survey123 to task sales representatives to visit clients and capture data about them. 

  • We use the network analyst VRP to schedule the sales representatives visits to clients and populate the schedule as assignments in workforce.  
  • We use navigator to assist the sales representative to get to the clients
  • We use Survey123 to record the visit to the client.

 

In the surveys a lot of the questions need to be pre-populated with data from a "master data" layer.  We add the layer to the field crew map in workforce and use the Survey123 URL schema to open the survey with its fields pre-populated from the master data by creating a hyperlink in the layer on the webmap. 

 

When we use the iOS version of workforce this works great. 

Launching Survey123 from Workforce iOS Application works well  Attribute data is transferred

 

When we use the Android verison of workforce it does not show the hyperlink.  Note that we are using the same web map.

No hyperlink is avialable on the field map from Android version of Workforce

 

Has anyone else come across this issue?

 

P.S. I know that we can launch Survey123 from Workforce directly but then we can only transfer the Location, WorkOrderID and GlobalID across.  We need to send quite a bit more.  

Outcomes