AnsweredAssumed Answered

Solution: Error when selecting my feature class to use with Survey123

Question asked by NEOMAPPER on Jul 19, 2018
Latest reply on Jul 19, 2018 by Philip.Wilson-esristaff

If anyone has problems trying to create a survey with a feature class due to the error below, please view the solution we had to do to resolve this issue. Hope this helps someone.

 

Error

The feature service does not meet the minimum requirement for a survey. The property supportsApplyEditsWithGlobalIds must be true.

 

Solution 

When you tried to create a survey using your ArcGIS Server feature service in the Survey123 Connect desktop application, you saw error: the feature service does not meet the minimum requirements for a survey. the property supportsApplyEditsWithGlobalIds must be true.

When we went to the service's REST endpoint, we saw that the 
Supports ApplyEdits With Global IDs parameter was set to false. To resolve the issue, we added an attribute index on the GlobalID field, checking the box that said 'Unique.' Specifically, we Right-clicked on feature class from ArcCatalog > Properties > Indexes > Add Attribute Index > Select GlobalID field > checked the box next to 'Unique' > OK > Apply >OK). Then, we overwrote the service, confirmed that the supportsApplyEditsWithGlobalIds property from REST changed to True, and were able to successfully create a survey from it using Survey123 Connect. 

Outcomes