AnsweredAssumed Answered

Public Survey123 for Portal Not Working

Question asked by Amanda.Huber@threeriversparks.org_trpd on Jul 17, 2018
Latest reply on Jul 25, 2018 by Amanda.Huber@threeriversparks.org_trpd

Hi Esri Community, 

 

We are currently having issues with a survey in Survey123 which has been shared publicly. This survey was published using Portal S123 Connect (version 2.7.72)  from an existing Portal Feature Service (Portal version 10.6). The survey is accessed by users via a web browser. Again, both the feature service, map image service, and survey have all been shared publicly.  

 

This survey has been working for the past two months with one token issue last month (which I opened a Support case for Case # 02124389 ). The public survey required a login for an unknown reason,  this was resolved with a republish from S123. We kept an eye on this survey and again exactly 1 month later we're experiencing a required sign in for a public facing survey. This time a simple republish is not resolving the issue. 

 

When viewing this survey in an incognito browser we see the login screen, and when taking it one step further and logging in we experience this error message: 

 

 

Esri support (Case # 02145603)  is telling me that S123 for Portal does not support public facing surveys? I find this hard to believe since it allows the built in option for surveys to be shared publicly and that this has been working roughly for the past two months.

 

Any information or further support would be much appreciated as this is affecting our live data. 

 

 

Thank you.

Outcomes