AnsweredAssumed Answered

Users connected to data in database, but no db connection exists in Catalog.....how?

Question asked by mbalxnder on May 3, 2018
Latest reply on May 11, 2018 by mbalxnder

Having a bit of a connundrum....new job, just sent folks through an upgrade from 10.3.1 to 10.5. Prior to upgrading, I would review user's connections (database and folder) in case I had to remap their locations. What I found on numerous occasions was that the users were able to view data from our RDBMS, but when I go to look in Catalog, there is no database connection established (see attached image).

 

I have looked in:

 

When you read the data source it simply and properly states the Production database. I just cannot tell where the data is coming from. In addition, when I use the Set Data Source option in ArcCatalog for the .mxd it reads C:\Users\<user>AppData\Roaming\ESRI\Desktop10.2\ArcCatalog\Connection to <db>.sql but this location doesn't even exist and it was from a completely different users profile that had never been logged onto that machine.

 

From what I understand, the one person created an .mxd and copeid it to multiple machines. I just don't know how the're able to access the data in the RDBMS if they don't have ANY connections defined at all.

 

Any help would be much appreciated. I know I can add the db and change their data sources, but I'd also like to do some clean up and understand what is going on. I feel like I am missing something big and obvious here, or maybe not?

Outcomes