AnsweredAssumed Answered

WMS Layer not showing in Webmercator projection

Question asked by ohb.marvin.kalani on Apr 12, 2018
Latest reply on Apr 13, 2018 by ohb.marvin.kalani

I like to show a Webmercator projection but instead always the WGS84 projection is shown.

 

I tried to set the SpatialReference in front of loading the WmsLayer but it still uses the WGS84 projection:

 

MainMapView = new MapView
            {
                Map = new Esri.ArcGISRuntime.Mapping.Map(SpatialReferences.WebMercator)
            };

 

The only solution is to disable WGS84 projections in the server component.

Is there any other way? In ArcgisRuntime 10.2.7 it was possible. Now with Version 100.x it seems the WMSLayer always tries to get the CRS:84 projection.

Outcomes