AnsweredAssumed Answered

ArcGIS Server - Config store issue

Question asked by RuchiraW_Caledon on Mar 5, 2018
Latest reply on Mar 14, 2018 by RuchiraW_Caledon

Hi,

We're running ArcGIS Server 10.5.1. 

We tried to setting up the server in a muti-machine cluster configuration on a Windows File Cluster but it was causing all sorts of issues with files locking up between the two servers (See error.jpg)Error while setting up config store in Windows File Cluster 

Our old file share, which is a NAS that uses SMB1 technology was working file but it's time to upgrade. We purchased a Dell EMC Unity SAN 450F utilizing NAS functionality. However, we're also having issues with publishing now where the publish happens successfully but service does not start. And throws this error:Error on EMC

 

The domain account used to install and run the ArcGIS Server has explicit Full Permissions to the file share (both file shares). And on the NAS, OPLOCKS is disabled. On Windows File Cluster, you're not able to change the OPLOCKS configuration. We tested the Server 10.5.1. on the older file share and it worked perfectly. No publishing issues and works quite quickly. However, the new Windows File Cluster and the new EMC NAS are giving us a quite a bit of trouble.

Has anybody else experienced this? If there a specific method to how the NAS or Windows File Clustering should be configured to work properly with ArcGIS Server?

Outcomes