AnsweredAssumed Answered

ArcGIS 10.5.1 create Enterprise Geodatabase error: PostgreSQL 9.4.8 DB

Question asked by suman.dasgupta on Jan 9, 2018
Latest reply on Jan 9, 2018 by suman.dasgupta

I am using the Create Enterprise Geodatabase tool to create a Geodatabase in postgreSQL. The tool fails with an error 

 

Error creating database. [ERROR: Failed to create postgres database gisdb (-1015).
Error: The Object being referenced does not exist (-1015).
]
Failed to execute (CreateEnterpriseGeodatabase)

 

I am using ArcGIS 10.5.1 Desktop for connecting to the database and postgreSQL version is 9.4.8. I have downloaded the postgreSQL DB from the Esri web site. I am able to connect to the database from the system where ArcGIS Client is installed through pgAdmin, so connection is not an issue.

 

I have copied the st_geometry dll files in the required directory as well, so that should not be an issue.

 

I have tried all possible options, with no luck, any idea what am I missing here

Attachments

Outcomes