AnsweredAssumed Answered

Various issues with SelectLayerByAttribute_management within Joined Features in Python

Question asked by darmynelson on Dec 14, 2017
Latest reply on Dec 15, 2017 by rvburton

The short version is this:

I have hundreds of original GDBs (backup copies) and the post-processed versions of same GDBs. The feature datasets, feature classes and attribute names are identical except for 5 additional fields in the originals. During the post processing those fields were eliminated during Append processes because they weren't to standard...no problem. My solution was to create feature layers, join based off attribute field, select where field IS NULL and field calculate values over. 

 

Problem: I received errors specific to arcpy.SelectLayerByAttribute() that suggest "Invalid Expression". I searched and tested recommendations, which sometimes are exact opposites of other recommendations (and folks claim it worked) but settled on the fact that it isn't truly an expression error (same syntax expressions work fine when applied to non-joined features). I decided to test manually to see what would happen and some wonky things occur where fields automatically assume properties of others when viewing tables in ArcMap, other fields from joined table don't show and I assume because of the similarity of datasets, features and attributes things are getting crossed in_memory??? I have tried a number of different things to no avail...print statements in there for my own sanity and the split tool called on because I thought same feature class name might be cause but still nada...it has to be something with joined attribute field name is my guess and yes I have tried wherecd = '"' + tFC + '_tLYR.createDate" IS NULL' among other recommendations.

 

Does anybody see anything off the top that would cause this error? Any help appreciated...

 

Outcomes