AnsweredAssumed Answered

GeoEvent Server 10.5.1 “No service was found”

Question asked by JSheldon on Dec 15, 2017
Latest reply on Dec 14, 2018 by crafty762

ArcGIS Server on this machine is ok, but whenever we try and access the geoevent server manager page we’re getting a “No service was found” message instead of the login page.  The geoevent server can’t start up correctly.  I tried several fixes from the forums:

 

  1. verified the license file
  2. removed cache and lock files from C:\Program Files\ArcGIS\Server\GeoEvent\data
  3. tried completely uninstalling, deleting files from c:\ProgramData\ and then reinstalling

 

In the karaf.log file (attached), I’m seeing this error…

 

2017-12-15 16:05:44,301 | ERROR | FelixStartLevel  | HttpClientService                | 100 - com.esri.ges.framework.httpclient - 10.5.1 | Failed to read certificate file at C:\arcgisserver\config-store\machines\AZGEOEVENT2\geoeventExport.pfx.cer: signed fields invalid

2017-12-15 16:05:44,302 | INFO  | FelixStartLevel  | HttpClientService                | 100 - com.esri.ges.framework.httpclient - 10.5.1 | signed fields invalid

 

I also see this entry...

 

2017-12-15 16:06:00,274 | ERROR | ator-Framework-0 | CuratorFrameworkImpl             | 386 - curator-framework - 3.1.0 | Background retry gave up
org.apache.curator.CuratorConnectionLossException: KeeperErrorCode = ConnectionLoss

 

The arcgis server is running with a valid third party cert, and I’m not sure why the .pfx file would even be renamed .cer?  The other certs in that directory, including the one used for ArcGIS Server are all ok.  In arcgis server admin all looks good.

 

You can access arcgis server manager at:

 

https://www.napermaps.com:6443/arcgis/manager

 

You can see from that it’s using a valid cert from Entrust. 

 

Any thoughts or suggestions would be great!  Unsure where to go from here. 

Attachments

Outcomes