RichBetts

Problem posting updates with FeatureServer

Discussion created by RichBetts on Jan 24, 2011
Latest reply on Feb 4, 2011 by RichBetts
Hello,

Im writing an feature editing application with the Flex API using FeatureServer in ArcGIS server 10. I can successfully add and delete features but am as yet unable to modify the geometry of polygon features in SDE/Oracle(10.2.0.1.0)

Heres an example of an update I'm attempting to apply with the FeatureLayer applyEdits html page in the Services Directory. 

[{"geometry":{"rings":[[[202912.407817124,898446.6930849041],[215361.05189148115,898469.7675136692],[216284.0283703202,883021.4500510262],[208761.0505275416,877310.3641501195],[201758.6872185752,883944.4265298652],[202912.407817124,898446.6930849041]]],"spatialReference":{"wkid":27700}},"attributes":{"OBJECTID":1602,"ID":11}}]

And here is the error that is returned...

Underlying DBMS error [ORA-01008: not all variables bound<br/>] [TABLE_OWNER.EDIT_TABLE]
Error applying edits.

Ive tried both the applyEdits page and the updateFeatures page with the same result.
Interestingly, If I change the word "geometry" to the word "shape" in the above (the geometry column in the database is actually called SHAPE) the result claims to be successful but if I check the geometry of the feature in the database it has not infact been updated.

OBJECTID is the only not null column in the dataset. The dataset is not versioned.

I would very much appreciate any thoughts or advice.

Cheers

Richard

Outcomes