AnsweredAssumed Answered

Python Type Error

Question asked by kat_hoenke_fws_col on Nov 16, 2017
Latest reply on Nov 16, 2017 by rastrauch

Hi All. 

I am  new to python and trying to build a small script that will take a double field, find its min and max, then use that min and max to calculate another double field. Eventually I want to make the workspace, fc, and fields parameters. See attached. I'm able to print the min and max, but when I try to use the update cursor, I keep returning the following error: 

 

Runtime error
line 19, in <module>
row[1] = (([0] - minimum) / (maximum - minimum))
TypeError: unsupported operand type(s) for -: 'list' and 'float'

 

 

 

I looked it up, but need some more direction. 

 

Any help is appreciated!

Thank you!

 

Script attached

Attachments

Outcomes