AnsweredAssumed Answered

"Load widget resource error" message when adding widget to app

Question asked by kenbuja on Sep 19, 2017
Latest reply on Sep 19, 2017 by kenbuja

I am developing a widget and have gotten to the point where I want to test its deployment before I start work on the Setting page. The app that it's currently in (id=2) works properly. However, when I create a new app and try to add it, I get the dreaded "Load widget resource error". There is no message in the console indicating where it is failing.

 

 

I am using the steps outlined here on setting up widget development using Yeoman and Grunt. Any changes to my code is synchronized with the directories C:\WebAppBuilderForArcGIS\server\apps\2\widgets and C:\WebAppBuilderForArcGIS\client\stemapp\widgets.

 

I have gone through all the functions in my code and commented out everything. I have done the same with the Widget.html page and the Setting.js and Setting.html pages. I still get the error when attempting to add it to a new project. If I click OK on the message, then OK on the Settings page, when I open the widget, I get the same error message and nothing in the console.

 

Where do I begin tracking down the problem with the widget?

Attachments

Outcomes