AnsweredAssumed Answered

App stopped working despite no change in code

Question asked by KGorton-esristaff Employee on Sep 5, 2017
Latest reply on Sep 5, 2017 by NManocha-esristaff

I have an app I wrote in AppStudio on Runtime 10.2.6 that was licensed at the Basic level. For several weeks it had been running fine until last week when I could no longer open it on my iPhone even though I had not changed any code or even opened the project. When I tried to run the app on my iPhone, it gave me the message indicating the developer was untrusted and until I trusted it in the iPhone settings, it would not run. However, going to iPhone settings to set the developer as trusted also failed. I had gone through these steps when I first deployed the app, so why did it suddenly stop trusting?

I tried to remake the app and redeploy it but I get messages that the app can not be transferred.

 

If I open the app page in https://developers.arcgis.com/applications/ and click Register App to generate a ClientID (again, which I previously did for this app) a message says 'There was an error loading OAuth credentials'.

 

Hopefully this is just a  matter of updating the licensing on the app? However, It seems most of the documentation is about licensing Runtime 100.1. I am in process of migrating the app, but in the meantime, what is required to bring this app back to life on Runtime 10.2.6?

 

Thanks,

Ken

Outcomes