AnsweredAssumed Answered

ArcMap: Text element anchor points do not work

Question asked by timmo1982 on Aug 23, 2017
Latest reply on Nov 24, 2017 by xander_bakker

Anchor points for text elements are not honored and seem to ALWAYS be anchored bottom centre.

 

Situation:

I have 3 lines of text in one text element which are centre aligned and are positioned correctly in the template.

I'm updating this via arcpy but the behaviour can be replicated in ArcMap directly as well.

 

You would expect (?) that by setting the anchor point at one of the top positions, the text box would maintain its upper most position and, say if adding another line of text, this would be added to the bottom. Alternatively, if removing the 2nd and 3rd lines, the 1st line would stay in the same position.

 

This does not happen.

 

You would expect (?) that by setting the anchor point at one of the middle (up-down) positions, the text would maintain its middle most position and, say if adding another line of text, this would be added midway between bottom top. Alternatively, if removing the 2nd and 3rd lines, the 1st line would move to the position of the original 2nd line.

 

This does not happen.

 

You would expect (?) that by setting the anchor point at one of the bottom positions, the text would maintain its lower most position and, say if adding another line of text to the bottom of the list, this would cause the text box to 'grow' upwards. Alternatively, if removing the 2nd and 3rd lines, the 1st line would move to where the 3rd line was.

 

This DOES happen..but!:

 

Setting the anchor point to the bottom left, you'd expect text to then grow out to the right while the left most position would stay the same. 

This does not happen (text grows left and right)

Setting the anchor point to the bottom right, you'd expect text to then grow out to the left while the right most position would stay the same. 

This does not happen (text grows left and right)

 

So of all of these combinations, the only anchor point that works is bottom center (i.e. adding new lines of text, the extent will grow at the top and adding more characters will grow both left and right)

 

Can anyone confirm this happens/does not happen and if an ESRI employee sees this, test and file a bug report?

Currently there appears to be no way of changing multi line text so that it is added in way that's consistent with how one would write a piece of text on paper (i.e. start at top left, new text is added to the bottom and the original text does not move)

 

Outcomes