AnsweredAssumed Answered

ArcGIS Pro 2.0 Python Manager Update Packages Not Working

Question asked by jvw122 on Aug 16, 2017
Latest reply on Aug 18, 2017 by jvw122

When I am in the Python Package Manager > Update Packages, it says I have 11 packages that need updated after I hit refresh. When I click Update All, they all flash and nothing happens. When I try to update one-by-one, they act like they are updating (blue progress bar moves), the UI flashes, and the package name stays in the Update Packages list and the Installed Packages list contains the same version. In fact, when I look in the Installed Packages list, the packages needing updated ALL say they are at the same version listed in the Update Packages list. Why is this happening?

 

I have been able to update on another computer, both of which I have admin rights, though I am pretty sure they are not full admin rights (work computers...). Could Active Directory rights or permissions be an issue or other security settings be an issue? I have tried running ArcGIS Pro as an admin, but no difference.

 

Here is a troubleshooting example I tried:

One package coming up in Updated Packages is 'spyder' version 3.1.4. I have tried updating it numerous times, but get the behavior described above. But when I run the Spyder application, it still gives me a notice that I am NOT running the most up to date version of 3.2.1. That version is not coming in as the updated version. So, I tried to Uninstall 'spyder', but it didn't uninstall...so that's another piece and I am stuck.

Outcomes