AnsweredAssumed Answered

ArcGIS Pro not updating attribute table, folder/file structures, gdb contents, etc

Question asked by tyschwartz on Jul 21, 2017
Latest reply on Dec 5, 2017 by Dan_Patterson

Hello,

 

I am noticing that in ArcGIS Pro (2.0, but in previous versions as well) when I run a tool that adds a field, that field isnt showing up in the Attribute Table when I open the layer/feature class that the tool was run on.

 

Example: I ran the Geoprocessing tool "Add Geometry Attributes" and after I run the tool, there is no new field that shows up in my attribute table.  I need to quit out of Pro and reopen for that field to show up in the attribute table.  

 

This follows a similar course with Pro not updating the folder trees or geodatabases when a feature class is added from outside of Pro (example if I move or create a feature class in ArcMap, Pro doesnt see it until I quit out of Pro, or manually refresh). However, there is no way to manually refresh an attribute table that I am aware of - so the only course of action is to quit out of Pro.  I think there is a lingering bug here that Pro is not "seeing" changes that are made to file structures, folder structures and attribute tables.  I think this behavior needs further investigation by ESRI and the QA/QC team.  I was hoping this would have been addressed in 2.0 but apparently the team is not aware of this issue.

 

I am wondering if others can also repeat this behavior

Outcomes