AnsweredAssumed Answered

Uploaded CSV is missing records in featureLayer

Question asked by schlot on Jun 9, 2017
Latest reply on Jun 12, 2017 by KGerrow-esristaff

I have a CSV file that contains a variety of columns, including latitude and longitude.  I've not done my loading of CSV data into a featureLayer, and this is the first time I've had any troubles.  It seems to be cutting off some of my records.  I should have 211.  Looking at the data of the featureLayer, first it had just 159 records.  I've tried to upload the data multiple times, once getting just 106 records to upload, and then only 105.

 

I feel like there is something buried in this data that I haven't spotted, but I've taken it to the plain text format, which generally strips out whatever hidden character is the problem, and back to CSV and I'm still having this problem.

 

I tried just hosting this is a service in my local AGS environment, and I have a similar problem.  Only in that case, I see no data at all, simply an Error statement when I attempt to review the data.  

 

I don't want to attempt to use a shape file, because the column names are all very long. 

Outcomes