AnsweredAssumed Answered

"No collectable layers are visible" message for feature layers with relationships

Question asked by niklas.krave_geogisgu on May 31, 2017
Latest reply on Aug 6, 2018 by mtorres_training

I am running in to issues with the collector app (only tested on android) when I try to create maps that include feature-to-feature relationships. 

 

Basically I want to create a "group" of layers with one main layer that is connected to multiple other "sub" layers with "one to many" relationships. By troubleshooting I have found out that the issue occurs as soon as I add the relationship, until then all layers work fine in collector but as soon as the relationship is added the sub layer stops showing when pressing the "+" in collector. The main layer works fine all the time but when only sub layers are present in the selection the message "No collectable layers are visible" shows on the map (I think, translated from Swedish). 

 

My setup is the following: 

A PostgreSQL database setup for ArcGIS Desktop. 

Feature services gets uploaded to ArcGIS Server (version 10.3.1). 

I add the services to AGOL through "Add item from the web" and link my feature service. 

I create a web map in AGOL with the service. Editing works fine all the time in the web map when in the AGOL environment.

The collector app uses the web map. Collector works fine until a service contains layers with relationships. 

 

So far I have only tried "one to many" relationships. I would prefer to use our internal ids for the relationships but I have also tried using Global ID:s but that does not fix the problem. 

 

Does anyone know if there is a way to fix this problem? 

 

Regards,

Niklas

Outcomes