AnsweredAssumed Answered

PostgreSQL st_geometry errors

Question asked by alchild on May 23, 2017
Latest reply on May 25, 2017 by alchild
Hi, I've gotten this same error twice in the past few months.  I'm currently running ArcGIS 10.5 (recently upgraded from 10.4) on a Windows 2012R server.  I'm also connected to a feature service sourced from a PostgreSQL 9.5 (upgraded from 9.3, I think, when I upgraded ArcGIS) geodatabase (gDB) on a CentOS 7 server.  Here are the actions which caused the same error under both ArcGIS/Postgres versions: 


1. I had ArcMap open (I wasn't connected to the Postgres gDB this time; I don't remember if I was connected the last time).
2. I tried to restart the Postgres service after making a change to its pg_hba.conf, but got an error about the lock file postmaster.pid already existing.  
3. I closed ArcMap.  
4. I tried restarting Postgres again; I was successful.  
5. I reopened ArcMap and tried to connect to the Postgres gDB, but got an error (attached) about how ArcMap couldn't load the st_geometry.so file (I'd had no trouble connecting to the gDB before getting this error).  
6. On the CentOS server, I deleted then recopied the exact same st_geometry.so file from the Windows server onto the CentOS server that was in place before the error.  
7. I tried reconnecting to the gDB in ArcMap; I was successful.  


Any ideas why I get this st_geometry.so file error?  I'd restarted the Postgres successfully many times after modifying its pg_hba.conf file; thankfully this error has only happened twice so far.

Outcomes