AnsweredAssumed Answered

Add-In Version Not Match & ArcMap crashed

Question asked by shaningesri on May 10, 2017
Latest reply on Jul 11, 2017 by shaningesri

I created an Add-Ins App using VS2012, FW4.5.  It works well on ArcMap 10.2 of my CPU.  However it does not work when it is loaded on other 2 CPUs.

In one of CPUs, ArcGIS 10.2 (same version as my one), clicking the Add-In icon leads to the close of the ArcMap.

In another CPU in which ArcGIS 10.4 Desktop is used.  After clicking on the tool icon, an error message pops out: "Add-In Version Not Match".  From the thread  Error: No GUI components found in this Add-In. Add-In version does not match , I checked the Config.esriaddinx file, in which

  <Targets>
    <Target name="Desktop" version="10.2" />
  </Targets>

Will the 10.2 be the problem of "Version Not Matched"?

Thanks if you can share your experience.

Outcomes