AnsweredAssumed Answered

GeoEvent Field Enricher (File) Not working

Question asked by Avery123 on Mar 24, 2017
Latest reply on Apr 3, 2017 by MBramer-esristaff

I am currently using GeoEvent Server 10.5 and attempting to use the Field Enricher (File) processor to populate existing fields in my GeoEvent object.  Unfortunately, the existing fields never get populated in the GeoEvent object after passing through the processor. I verified that the value in join field in the GeoEvent object is also in the lookup file, and that the enrichment fields exist in both the file and the GeoEvent.  I tried adding new fields as well, but this also did not work.  I do not see any errors in the GeoEvent logs for this processor.

 

As a test, I also tried using the Field Enricher (Feature Service) and got the same result, but I was able to get that field enricher to add new fields to my GeoEvent, but never able to populate the existing GeoEvent.

 

Has any one else been having trouble with this processor, or know of probable reasons for it not working?

Outcomes