AnsweredAssumed Answered

Remove Domain Not Working? Field restricted to coded values even when domain shows as empty in all other screens...

Question asked by tcrobe04_SMUMN on Mar 21, 2017
Latest reply on Mar 22, 2017 by tcrobe04_SMUMN

Field in attribute table was assigned a domain somehow during conversion from other datasource.

How this could even have happened is unknown, as the tool used did not have the options or ability to begin influencing domains and assignments of domains. 

 

We need this field to be editable.

Went to edit it, and it restricts user to list of coded values for a domain that's been assigned. 

 

Closed ArcMap, removed domain assignment in ArcCatalog, re-opened ArcMap.

Does not show domain assigned in any properties screen for the feature class or the field itself in the attribute table. 

 

Went to edit it again... Still restricts user to drop down of coded values from domain. 

 

Tried Remove Domain from Field tool... could not select field, as it does not show as assigned any domain in any other UI screen. 

 

Tried Using Assign Domain to Field, then Remove Domain from Field. Still doesn't work. 

Tried dropping it into fresh map file. 

Tried on separate computer with fresh map.

 

All properties screens and domain/fields screens show that the field is no longer assigned any domain except text value, 254 char.

 

Still, no user can edit the field except within these coded values somehow.

 

How is this possible? Thanks in advance for any help! 

Outcomes